This issue has been resolved; however, there is a backlog of leads being processed. We estimate that all leads will be processed by 10:15 a.m. PST, and we will confirm here when the process is caught up.
Posted Oct 06, 2025 - 09:13 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 06, 2025 - 09:13 PDT
Update
This issue has been resolved; however, there is a backlog of leads being processed. We estimate that all leads will be processed by 10:15 a.m. PST, and we will confirm here when the process is caught up.
Posted Oct 06, 2025 - 09:13 PDT
Update
We are continuing to implement a fix.
Posted Oct 06, 2025 - 07:48 PDT
Monitoring
We have identified the issue and are currently implementing a fix.
Posted Oct 06, 2025 - 07:19 PDT
Update
We are continuing to investigate this issue.
Posted Oct 06, 2025 - 06:58 PDT
Update
Leads from last night are not yet available in all accounts - we are working urgently to restore them.
Posted Oct 06, 2025 - 06:15 PDT
Investigating
We are finalizing updates done over the weekend; there may be delays to the system today.