We are continuing to closely monitor this update. Thank you so much!
Posted Mar 03, 2026 - 08:38 PST
Update
We are continuing to closely monitor this update. Thank you for your patience as we work through any delays in AI responses or appointment confirmations.
Posted Mar 02, 2026 - 08:35 PST
Monitoring
Expect delays for AI messaging today. Ability to manually respond fully operational.