Inbound email delayed
Incident Report for SendSmart
Resolved
The problem is resolved -- emails and leads are now being delivered. Delayed emails are also being delivered.
Posted Nov 23, 2022 - 08:15 PST
Identified
The problem has been identified and will be resolved very shortly
Posted Nov 23, 2022 - 07:41 PST
Investigating
Delivery of inbound email messages, including leads, is delayed. We are working the problem and should have a resolution within an hour. No leads or emails will be lost.
Posted Nov 23, 2022 - 06:48 PST
This incident affected: SendSmart Email.