Maintenance
Incident Report for SendSmart
Resolved
This incident has been resolved.
Posted Jul 09, 2019 - 12:04 PDT
Monitoring
Our systems are under maintenance until 10am PST.
Posted Jul 09, 2019 - 09:27 PDT